Salı , 19 Mart 2019

EXCELDE ÖNEMLİ FONKSİYONLAR


EXCELDE SIK KULLANILAN FONKSİYONLAR

=A3*15 A3 hücresindeki sayı ile 15 sayısının çarpımı. =(B2+C2+D2)/3 B2, C2 ve D2 hücrelerini toplayıp 3’e böler. 4.2. Bazı Excel Fonksiyonları 4.2.1. TOPLA Fonksiyonu Hücre aralığındaki tüm sayıları toplar. Sözdizimi TOPLA(sayı1;sayı2;…) Sayı1, sayı2, … toplamını veya toplam değerini istediğiniz 1 ile 255 arasında bağımsız değişkendir. Örnek =TOPLA(A2;B5;D8)                         A2, B5, D8 hücrelerinin toplamını bulur. =TOPLA(B2:B12)                              B2 ile B12 hücreleri arasındaki hücrelerin toplamını bulur. 4.2.2. ÇARPIM Fonksiyonu Bağımsız değişken olarak verilen tüm sayıları çarpar ve çarpımlarını verir. Sözdizimi ÇARPIM(sayı1;sayı2;…) Sayı1, sayı2, … çarpmak istediğiniz 1 ile 255 arasında sayıdır. Örnek

AFormülAçıklama
1Veri1=ÇARPIM(A2:A4)A2 ile A4 arasındaki sayıları çarpar. 5*3*4 işlemini gerçekleştirip 60 değerini bulur.
252=ÇARPIM(A2:A4;2)A2 ile A4 arasındaki sayıları çarptıktan sonra çıkan sonucu 2 ile çarpar. Sonuç 120 olur.
333
444

4.2.3. Yüzde İşlemi Herhangi bir hücrede belirtilen sayının, belirtilen oran kadar yüzdesinin hesaplar.Örnek B hücrelerinde verilen Vize notlarının yüzdeleri C hücrelerinde hesaplanmıştır.

ABC
1AdıVize NotuVize Notunun %25’i
2Ayşe45=B2*25%
3Fatma67=B3*25%
4Ali70=B4*25%
5Can54=B5*25%

4.2.4. MİN Fonksiyonu Değer kümesindeki en küçük sayıyı verir. Sözdizimi MİN(sayı1;sayı2;…Sayı1, sayı2, … minimum değerini bulmak istediğiniz 1 ile 255 arasında sayılardır. Örnek

ABFormülAçıklama (Sonuç)
1Veri=MİN(A2:A6)A2 ile A6 hücreleri arasındaki sayıların en küçüğü (2)
210=MİN(A2;A6)A2 ile A6’nın en küçüğü (9)
37=MİN(A3;A5;3)A3, A5 ve 3 arasından en küçüğü (3)
42
527
69

4.2.5. MAK Fonksiyonu Değer kümesindeki en büyük sayıyı verir. Sözdizimi MAK(sayı1;sayı2;…Sayı1, sayı2, … maksimum değerini bulmak istediğiniz 1 ile 255 arasında sayılardır. Örnek

ABFormülAçıklama (Sonuç)
1Veri=MAK(A2:A6)A2 ile A6 hücreleri arasındaki sayıların en büyüğü (27)
210=MAK(A2;A6)A2 ile A6’nın en büyüğü (10)
37=MAK(A3;A5;30)A3, A5 ve 3 arasından en büyüğü (30)
42
527
69

4.2.6. ORTALAMA Fonksiyonu Bağımsız değişkenlerin ortalamasını (aritmetik ortalama) verir. SözdizimiORTALAMA(sayı1;sayı2;…Sayı1,sayı2, … ortalamasını istediğiniz 1 ile 255 arasında sayısal bağımsız değişkenlerdir. Örnek

ABFormülAçıklama (Sonuç)
1Veri=ORTALAMA(A2:A6)A2 ile A6 hücreleri arasındaki sayıların ortalaması (11)
210=ORTALAMA(A2;A6)A2 ile A6’nın ortalaması (6)
37=ORTALAMA(A3;A5;2)A3, A5 ve 2’nin ortalaması (12)
49
527
62

4.2.7. YUVARLA Fonksiyonu Sayıyı belirlenen sayıda basamağa yuvarlar. SözdizimiYUVARLA(sayı;sayı_rakamlarSayı yuvarlamak istediğiniz sayıdır. Sayı_rakamlar sayıyı yuvarlamak istediğiniz basamak sayısını belirtir.

  • Sayı_basamaklar 0’dan (sıfırdan) büyükse, sayı belirtilen ondalık hane sayısına yuvarlanır.
  • Sayı_basamaklar 0 ise, sayı en yakın tamsayıya yuvarlanır.
  • Sayı_basamaklar 0’dan küçükse, sayı ondalık virgülün soluna yuvarlanır.
AB
1FormülAçıklama (Sonuç)
2=YUVARLA(2,15;1)2,15’i bir ondalık basamak olacak biçimde yuvarlar (2,2)
3=YUVARLA(2,139;1)2,139’u bir ondalık basamak olacak biçimde yuvarlar (2,1)
4=YUVARLA(-1,475;2)-1,475’i iki ondalık basamak olacak biçimde yuvarlar (-1,48)
5=YUVARLA(21,5;-1)21,5’i ondalık virgülün soluna bir ondalık basamak yuvarlar (20)

4.2.8. KAREKÖK Fonksiyonu Pozitif bir karekök verir. Sözdizimi KAREKÖK(sayıSayı karekökünü bulmak istediğiniz sayıdır.

  • Sayı negatifse, KAREKÖK fonksiyonu #SAYI! hata değeri verir.

Örnek

ABFormülSonucu
1Veri=KAREKÖK(25)25’in karekökü (5)
2-16=KAREKÖK(A2)A2’deki sayının karekökünü verir. Sayı negatif olduğundan hata verir. (#SAYI!)
3

4.2.9. KUVVET Fonksiyonu Üssü alınmış bir sayının sonucunu verir. Sözdizimi KUVVET(sayı;üsSayıtemel sayıdır. Gerçek sayılar olabilir. Üs temel sayının yükseltileceği üstür.

  • Temel sayının yükseltileceği üssü göstermek için KUVVET fonksiyonu yerine “^” işleci kullanılabilir; örneğin 5^2.
FormülAçıklama (Sonuç)
=KUVVET(5;2)5’in karesi (25)
=KUVVET(98,6;3,2)98,6 üssü 3,2 (2401077)
=KUVVET(4;5/4)4 üssü 5/4 (5,656854)

4.2.10. BUGÜN Fonksiyonu Geçerli tarihin seri sayısını verir. Seri sayısı, Microsoft Excel’in tarih ve zaman hesaplamalarında kullandığı tarih-zaman kodudur. Hücre biçimi fonksiyon girilmeden önce Genel ise, sonuç tarih olarak biçimlendirilir. Sözdizimi BUGÜN( ) Excel, tarihleri ardışık seri numaralar olarak saklar ve böylece tarihler hesaplamalarda kullanılabilir. Varsayılan değer olarak, 1 Ocak 1900 tarihi için 1 seri numarası kullanılır. Bu tarihten 39.448 gün sonrasına denk düşen 1 Ocak 2008’in seri numarası ise 39448 olur.

4.2.11. ŞİMDİ Fonksiyonu Geçerli tarih ve zamanın seri numarasını verir. Hücre biçimi fonksiyon girilmeden önce Genel ise, sonuç tarih olarak biçimlendirilir. Sözdizimi ŞİMDİ( ) Microsoft Excel hesaplamalarda kullanılabilmeleri için tarihleri sıralı seri numaraları olarak saklamaktadır. Varsayılan olarak, 1 Ocak 1900’ün seri numarası 1’dir, bundan dolayı 1 Ocak 1900’den 39.448 gün sonra olması nedeniyle 1 Ocak 2008’in sayısı 39448’dir. Seri sayıda ondalık noktanın sağındaki sayılar saati, soldakiler de tarihi gösterir. Örneğin, seri sayısı 0,5, saat olarak öğlen 12:00 gösterir. Yalnızca çalışma sayfası hesaplandığında veya fonksiyonu içeren makro çalıştırıldığında, ŞİMDİ fonksiyonu değişir. Bu sürekli olarak güncellenmez.


4.2.12. 
HAFTANINGÜNÜ Fonksiyonu Bir tarihe karşılık gelen haftanın gününü verir. Varsayılan değer olarak, gün, 1’den (Pazar) 7’ye (Cumartesi) kadar bir tamsayı olarak verilir. SözdizimiHAFTANINGÜNÜ(seri_no, döndür_türSeri_no bulmaya çalıştığınız günün tarihini gösteren ardışık sayıdır. Tarihler, TARİH fonksiyonu kullanılarak girilmiş veya başka formüller veya fonksiyonlarla elde edilmiş olmalıdır. Örneğin, Mayıs 2008’in 23. günü için TARİH(2008,5,23) formülünü kullanın. Tarihler metin biçiminde girilmişse sorunlar çıkabilir. Döndür_tür sonuç değerinin türünü belirleyen bir türdür.

Döndür_türVerilen Sayı
1 veya belirtilmemiş1’den (Pazar) 7’ye (Cumartesi) kadar sayılar. Microsoft Excel’in önceki sürümlerinde olduğu gibi.
21’den (Pazartesi) 7’ye (Pazar) kadar sayılar.
30’den (Pazartesi) 6’ye (Pazar) kadar sayılar.

Örnek

ABFormülAçıklama (Sonuç)
1Veri=HAFTANINGÜNÜ(A2)1’den (Pazar) 7’ye (Cumartesi) kadar sayılarla gösterilen haftanın günü (5)
214.02.2008
3=HAFTANINGÜNÜ(A2,2)1’den (Pazartesi) 7’ye (Pazar) kadar sayılarla gösterilen haftanın günü (4)
4
5=HAFTANINGÜNÜ(A2,3)0’dan (Pazartesi) 6’ya (Pazar) kadar sayılarla gösterilen haftanın günü (3)
6

4.2.13. BÜYÜKHARF Fonksiyonu Metni büyük harfe çevirir. Sözdizimi BÜYÜKHARF(metinMetinbüyük harfe çevrilmesini istediğiniz metindir. Metin bir başvuru veya metin dizesi olabilir. Örnek

ACFormülAçıklama (Sonuç)
1Veri=BÜYÜKHARF(A2)İlk dizenin büyük harfe dönüştürülmüş biçimi (TOPLAM)
2Toplam=BÜYÜKHARF(A3)İkinci dizenin büyük harfe dönüştürülmüş biçimi (VERİM)
3verim

4.2.14. KÜÇÜKHARF Fonksiyonu Metni küçük harfe çevirir. Sözdizimi KÜÇÜKHARF(metinMetinküçük harfe çevrilmesini istediğiniz metindir. Metin bir başvuru veya metin dizesi olabilir. Örnek

ABFormülAçıklama (Sonuç)
1Veri=KÜÇÜKHARF(A2)İlk dizenin küçük harfe çevrilmiş biçimi (e. e. birliği)
2E. E. Birliği=KÜÇÜKHARF(A3)Son dizenin küçük harfe çevrilmiş biçimi (apt. 2b)
3Apt. 2B

4.2.15. SOLDAN Fonksiyonu SOLDAN, bir metin dizesindeki belirttiğiniz karakter sayısına bağlı olarak ilk karakter veya karakterleri verir. SOLDAN(metin;sayı_karakterlerMetin ayıklamak istediğiniz karakterleri içeren metin dizisidir. Sayı_karakterler SOLDAN fonksiyonunun ayıklamasını istediğiniz karakter sayısını belirler.

  • Sayı_karakterler sıfırdan büyük veya sıfıra eşit olmalıdır.
  • Sayı_karakterler metin uzunluğundan büyükse, SOLDAN fonksiyonu tüm metni verir.
  • Sayı_karakterler belirtilmezse, 1 olduğu varsayılır.
ABFormülAçıklama (Sonuç)
1Veri=SOLDAN(A2;5)Birinci dizedeki ilk beş karakter (Satış)
2Satış Fiyatı=SOLDAN(A3)İkinci dizedeki ilk karakter (İ)
3İsveç

4.2.16. SAĞDAN Fonksiyonu SAĞDAN, bir metin dizesindeki belirttiğiniz karakter sayısına bağlı olarak son karakter veya karakterleri verir. SAĞDAN(metin;sayı_karakterlerMetin ayıklamak istediğiniz karakterleri içeren metin dizisidir. Sayı_karakterler SAĞDAN fonksiyonunun ayıklamasını istediğiniz karakter sayısını belirler.

  • Sayı_karakterler sıfırdan büyük veya sıfıra eşit olmalıdır.
  • Sayı_karakterler metin uzunluğundan büyükse, SAĞDAN fonksiyonu tüm metni verir.
  • Sayı_karakterler belirtilmezse, 1 olduğu varsayılır.
ABFormülAçıklama (Sonuç)
1Veri=SAĞDAN(A2;6)İlk dizenin son altı karakterini verir (Fiyatı)
2Satış Fiyatı=SAĞDAN(A3)İkinci dizedeki son karakter (ı)
3Stok Numarası

4.2.17. UZUNLUK Fonksiyonu UZUNLUK metin dizesindeki karakter sayısını verir. SözdizimiUZUNLUK(metinMetin uzunluğunu bulmak istediğiniz metindir. Boşluklar da karakter olarak sayılır.Örnek

ABFormülAçıklama (Sonuç)
1Veri=UZUNLUK(A2)A2’de bulunan yazıdaki karakter sayısı (3)
2MYO=UZUNLUK(A3)A2’de bulunan yazıdaki karakter sayısı (21)
3Nevşehir Üniversitesi

4.2.18. BİRLEŞTİR Fonksiyonu İki veya daha çok metin dizesini bir metin dizesi şeklinde birleştirir.Sözdizimi BİRLEŞTİR (metin1;metin2;…Metin1; metin2; … tek bir öğe olarak birleştirilecek 2 ile 255 arasında metin öğesidir. Metin öğeleri; metin dizeleri, sayılar veya tek hücre başvuruları olabilir.

  • Metin öğelerini birleştirmek için BİRLEŞTİR fonksiyonu yerine VE işareti (&) hesaplama işlecini de kullanabilirsiniz. Örneğin, =A1&B1, BİRLEŞTİR(A1;B1) ile aynı sonuç değerini verir.

Örnek

ABFormül=BİRLEŞTİR(A2;” “;A3;” için nehir yoğunluğu “;A4;”/m”)
1Veri
2Tatlı su alabalığıAçıklama (Sonuç)Yukarıdaki verilerden gelen bir cümleyi birleştirir (Tatlı su alabalığı türleri için nehir yoğunluğu 32/m)
3türleri
432

4.2.19. PARÇAAL Fonksiyonu PARÇAAL belirlediğiniz konumdan başlayarak, belirlediğiniz sayıda karakter esasında bir metin dizesinden belirli sayıda karakter verir. Sözdizimi PARÇAAL (metin;başlangıç_sayısı;sayı_karakterlerMetin ayıklamak istediğiniz karakterleri içeren metindir.Başlangıç_sayısı metinde ayıklamak istediğiniz ilk karakterin konumudur. Metin’deki ilk karakterin başlangıç_sayısı 1’dir ve böylece devam eder. Sayı_karakterler PARÇAAL ‘ın metinden vermesini istediğiniz karakter sayısını belirler.

  • Başlangıç_sayısı, metin uzunluğundan büyükse PARÇAAL fonksiyonu “” (boş metin) verir.
  • Başlangıç_sayısı, metin büyüklüğünden küçük, ancak başlangıç_sayısı ve sayı_karakterler birlikte metin uzunluğunu aşarsa, PARÇAAL metnin sonuna kadar olan karakterleri verir.
  • Başlangıç_sayısı 1’den küçükse, PARÇAAL fonksiyonu #DEĞER! hata değeri verir.
  • Sayı_karakterler negatifse, PARÇAAL fonksiyonu #DEĞER! hata değeri verir.

Örnek

ACFormülAçıklama (Sonuç)
1Veri=PARÇAAL(A2;1;5)Birinci karakterle başlayan ilk beş karakter (Sulak)
2Sulak Arazi= PARÇAAL (A2;7;20)Yedinci karakterden başlayan yirmi karakter (Arazi)
3= PARÇAAL (A2;20;5)Başlangıç noktasının dizenin uzunluğundan daha büyük olması nedeniyle boş metin verilir ()
4

4.2.20. KIRP Fonksiyonu Sözcükler arasındaki tek boşluklar dışında metinden tüm boşlukları kaldırır. Boşlukları düzenli olmayan, başka bir uygulamadan aldığınız metin üzerinde KIRP işlevini kullanın. SözdizimiKIRP(metinMetin içinden boşlukların kaldırılmasını istediğiniz metindir. Örnek

FormülAçıklama (Sonuç)
=KIRP(” İlk Çeyrek Gelirleri  “)Formüldeki metnin (İlk Çeyrek Gelirleri) başındaki ve sonundaki boşlukları kaldırır.

4.2.21. BUL Fonksiyonu BUL, bir metin dizesini başka bir metin dizesi içinde bulur ve ikinci metin dizesinin ilk karakterine göre ilk metin dizesinin başlangıç konumunun sayısını döndürür. SözdizimiBUL(bul_metin;metin;başlangıç_sayısıBul_metin bulmak istediğiniz metindir. Metin bulmak istediğiniz metni içeren metindir. Başlangıç_sayısı aramanın başlatılacağı karakteri belirtir. Metin’deki ilk karakter sayısı 1’dir. Başlangıç_sayısı belirtilmezse 1 olduğu varsayılır.

  • BUL büyük/küçük harf duyarlıdır ve joker karakter kullanımına izin vermez.
  • Bul_metin “” (boş metin) ise, BUL arama dizesindeki ilk karakteri (başlangıç_sayısı veya 1 numaralı karakter) seçer.
  • Bul_metinde joker karakter olamaz.
  • Bul_metin, metinde yoksa BUL fonksiyonu #DEĞER! hata değeri verir.
  • Başlangıç_sayısı sıfırdan büyük değilse, BUL fonksiyonu #DEĞER! hata değeri verir.
  • Başlangıç_sayısı, metinin uzunluğundan büyükse, BUL fonksiyonu #DEĞER! hata değeri verir.
  • Belirli sayıda karakteri atlamak için başlangıç_sayısı’nı kullanın. Örneğin BUL fonksiyonunu kullandığınızı ve “AGF0093.GençErkekKıyafeti” metin dizesiyle çalıştığınızı varsayalım. Metin dizesinin açıklayıcı bölümündeki ilk “G” karakterinin sayısını bulmak için, metnin seri numarası kısmının aranmaması amacıyla başlangıç_sayısı’nı 8 olarak belirtin. BUL fonksiyonu 8. karakterden başlar, bir sonraki karakterde bul_metin’i bulur ve 9 sayısını verir. BUL, başlangıç_sayısı 1’den büyükse atladığınız karakterleri de sayarak, karakter sayısını her zaman metin’in başlangıcını esas alarak verir.

Örnek

ACFormülAçıklama (Sonuç)
1Veri=BUL(“M”;A2)Birinci “M” konumu (1)
2Meryem Meriç=BUL(“m”;A2)Birinci “m” konumu (6)
3=BUL(“M”;A2;3)Üçüncü karakterle başlayan dizede, birinci “M” konumu (8)
4

4.2.22. ETOPLA Fonksiyonu Verilen ölçütle belirlenen hücreleri toplar. SözdizimiETOPLA(aralık;ölçüt;toplam_aralığıAralık ölçütlerle değerlendirilmesini istediğiniz hücre aralığıdır. Her aralıktaki hücreler, sayı veya sayı içeren ad, dizi veya başvuru olmalıdır. Boşluk ve metin göz ardı edilir.Ölçüt hangi hücrelerin toplanacağını belirleyen bir sayı, ifade veya metin biçimindeki ölçüttür. Örneğin, Ölçüt 32, “32”, “>32” veya “elmalar” olarak ifade edilebilir. Toplam_aralığı aralıkta karşılık gelen hücreler ölçüte uyuyorsa eklenecek gerçek hücrelerdir. Toplam_aralığı atlanırsa, aralıktaki hücreler hem ölçütler tarafından değerlendirilir, hem de ölçütleri karşılıyorsa eklenir.

  • Toplam_aralığının aralıkla aynı boyutta ve şekilde olması gerekmez. Eklenen gerçek hücreler başlangıç hücresi olarak toplam_aralığında üst, sol hücreler kullanılarak saptanıp aralıkla boyut ve şekil olarak uygun olan hücreleri de ekler. Örneğin:
Aralık aşağıdaki gibiVe toplam_aralığı aşağıdaki gibiyseGerçek hücreler aşağıdaki gibi olur
A1:A5B1:B5B1:B5
A1:A5B1:B3B1:B5
A1:B4C1:D4C1:D4
A1:B4C1:C2C1:D4

Ölçütlerde joker karakterler, soru işareti (?) ve yıldız işareti (*) kullanabilirsiniz. Soru işareti tek karakter bulurken, yıldız işareti bir dizi karakter bulur. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterin önüne bir tilde işareti (~) koyun Örnek

ABCFormülAçıklama (Sonuç)
1Mülk DeğeriKomisyon=ETOPLA(A2:A5;”>160000″;B2:B5)160.000’in üzerindeki mülk değerleri için komisyonların toplamı (63.000)
2100.0007.000
3200.00014.000
4300.00021.000=ETOPLA(A2:A5;”>160000″)160.000’in üzerindeki mülk değerleri toplamı (900.000)
5400.00028.000
=ETOPLA(A2:A5,”=300000″,B2:B3)300.000′ e eşit mülk değerleri için komisyonların toplamı (21.000)

4.2.23. EĞERSAY Fonksiyonu EĞERSAY işlevi, bir aralıkta yer alan ve belirttiğiniz tek bir ölçüte uyan hücrelerin sayısını sayar. Örneğin, belirli bir harfle başlayan tüm hücreleri veya belirttiğiniz bir sayıdan daha küçük ya da daha büyük sayılar içeren tüm hücreleri sayabilirsiniz. Örneğin, A sütununda görev listesinin ve B sütununda da her göreve atanmış kişinin adının bulunduğu bir çalışma sayfanız olduğunu varsayalım. EĞERSAY işlevini kullanarak bir kişinin adının B sütununda kaç kez geçtiğini sayabilir, bu yolla söz konusu kişiye kaç görev atandığını saptayabilirsiniz. Örneğin: =EĞERSAY(B2:B25,”Neşe”) SözdizimiEĞERSAY(aralık, ölçüt) EĞERSAY işlevinin sözdizimi aşağıdaki bağımsız değişkenleri (bağımsız değişken: Bir eylem, olay, yöntem, özellik, fonksiyon veya yordama bilgi sağlayan bir değer.) içerir: Aralık:  Gerekli. Numaralar veya adlar, diziler ya da sayı içeren başvurular da içinde olmak üzere sayılacak bir veya birden çok hücre. Boşluk ve metin değerleri göz ardı edilir. Ölçütler:  Gerekli. Hangi hücrelerin sayılacağını tanımlayan sayı, ifade, hücre başvurusu ya da metin dizesi. Örneğin, ölçüt 32, “>32”, B4, “elmalar” veya “32” olarak gösterilebilir. Not Ölçütte, soru işareti (?) ve yıldız işareti (*) gibi joker karakterler kullanabilirsiniz. Soru işareti tek karakter bulurken, yıldız işareti bir dizi karakter bulur. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterden önce bir tilde işareti (~) koyun. Ölçütler büyük/küçük harfe duyarlı değildir; örneğin, “elmalar” dizesiyle “ELMALAR” dizesi aynı hücreleri eşleştirir.Örnek

ABC
1VeriVeri
2elma32
3portakal54
4Şeftali75
5Elma86
6
7FormülAçıklamaSonuç
8=EĞERSAY(A2:A5;”elma”)A2 ile A5 arasında yer alan elma sözcüğünü içeren hücrelerin sayısı2
9=EĞERSAY(A2:A5;A4)A2 ile A5 arasında yer alan şeftali sözcüğünü içeren hücrelerin sayısı1
10=EĞERSAY(A2:A5;A3) + EĞERSAY(A2:A5;A2)A2 ile A5 arasında yer alan portakal ve elma sözcüklerini içeren hücrelerin sayısı3
11=EĞERSAY(B2:B5;”>55”)B2 ile B5 arasında yer alan ve 55’ten büyük bir değer içeren hücrelerin sayısı2
12=EĞERSAY(B2:B5;”<>”&B4)B2 ile B5 arasında yer alan ve değerleri 75’e eşit olmayan hücrelerin sayısı3
13

4.2.24. VE Fonksiyonu Tüm bağımsız değişkenleri DOĞRU’ysa DOĞRU’yu verir; Bir ya da daha fazla bağımsız değişkeni YANLIŞ’sa YANLIŞ’ı verir. Sözdizimi VE(mantıksal1;mantıksal2; …)Mantıksal1;mantıksal2;… DOĞRU ya da YANLIŞ olabilen, test etmek istediğiniz 1 ile 255 arası koşuldur.

  • Bağımsız değişkenler, DOĞRU veya YANLIŞ gibi mantıksal değerler oluşturmalı veya mantıksal değerler içeren diziler veya başvurular olmalıdır.
  • Bir dizi veya başvuru bağımsız değişkeni metin veya boş hücreler içeriyorsa, bu değerler dikkate alınmaz.
  • Belirlenen aralık hiçbir mantıksal değer içermiyorsa VE işlevi #DEĞER! hata değerini verir.

Örnek

FormülAçıklama (Sonuç)
=VE(DOĞRU; DOĞRU)Tüm bağımsız değişkenler DOĞRU (DOĞRU)
=VE(DOĞRU; YANLIŞ)Bir bağımsız değişken YANLIŞ (YANLIŞ)
=VE(2+2=4; 2+3=5)Tüm bağımsız değişkenler DOĞRU olarak değerlendirildi (DOĞRU)
ACFormülAçıklama (Sonuç)
1Veri=VE(1<A2; A2<100)50, 1 ile 100 arasında olduğu için (DOĞRU)
250=VE(1<A3; A3<100)A3, 1’den büyük olmasına rağmen 100’den küçük olduğu için yanlış
3104

4.2.25. YADA Fonksiyonu Bağımsız değişkenlerden biri DOĞRU’ysa DOĞRU’yu verir; tüm bağımsız değişkenler YANLIŞ’sa da YANLIŞ’ı verir. Sözdizimi YADA(mantıksal1;mantıksal2;…Mantıksal1, mantıksal2, … DOĞRU veya YANLIŞ olduğunu sınamak istediğiniz 1 ile 255 arasındaki koşullardır.

  • Bağımsız değişkenlerin DOĞRU veya YANLIŞ gibi mantıksal değerleri veya mantıksal değerler içeren dizileri veya başvuruları değerlendirmeleri gerekir.
  • Bir dizi veya başvuru bağımsız değişkeni metin veya boş hücreler içeriyorsa, bu değerler dikkate alınmaz.
  • Belirtilen aralık mantıksal değer içermiyorsa, YADA fonksiyonu #DEĞER! hata değeri verir.
  • Bir dizide bir değerin olup olmadığını görmek için bir YADA dizi formülü kullanabilirsiniz.

Örnek

FormülAçıklama (Sonuç)
=YADA(DOĞRU)Bir bağımsız değişken DOĞRU’dur (DOĞRU)
=YADA(1+1=1;2+2=5)Tüm bağımsız değişkenler YANLIŞ olarak değerlendirilir (YANLIŞ)
=YADA(DOĞRU;YANLIŞ;DOĞRU)En azından bir bağımsız değişken DOĞRU’dur (DOĞRU)

4.2.26. DEĞİL Fonksiyonu Bağımsız değişkeninin değerini tersine çevirir. Bir değerin belirli bir değere eşit olup olmadığını denetlemek istediğinizde DEĞİL fonksiyonunu kullanın. Sözdizimi DEĞİL(mantıksal)Mantıksal DOĞRU veya YANLIŞ olarak değerlendirilebilecek değerdir.

  • Mantıksal YANLIŞ ise, DEĞİL DOĞRU’yu; mantıksal DOĞRU ise, DEĞİL YANLIŞ’ı verir.

Örnek

FormülSonuç (Açıklama)
=DEĞİL(YANLIŞ)YANLIŞ’ın tersini verir (DOĞRU)
=DEĞİL(1+1=2)DOĞRU olarak değerlendirilen bir denklemin tersini verir (YANLIŞ)

4.2.27. EĞER Fonksiyonu Belirttiğiniz koşul DOĞRU olarak değerlendirilirse bir değer, YANLIŞ olarak değerlendirilirse başka bir değer verir. Değerler ve formüller üzerinde koşullu sınamalar yürütmek için EĞER fonksiyonunu kullanın. SözdizimiEĞER(mantıksal_sınama;eğer_doğruysa_değer;eğer_yanlışsa_değerMantıksal_sınama DOĞRU veya YANLIŞ olarak değerlendirilebilecek herhangi bir değer veya deyim. Örneğin, A10=100, mantıksal bir deyimdir; A10 hücresindeki değer 100’e eşitse, deyim DOĞRU olarak değerlendirilir. Tersi durumda, YANLIŞ olarak değerlendirilir. Bu bağımsız değişken herhangi bir karşılaştırma hesabı işleci kullanabilir. Eğer_doğruysa_değer mantıksal_sınama DOĞRU ise verilen değerdir. Örneğin, metin dizesindeki bu bağımsız değişken “Bütçe içinde” ise ve mantıksal_sınama bağımsız değişkeni DOĞRU olarak değerlendirilirse, EĞER fonksiyonu “Bütçe içinde” metnini görüntüler. Mantıksal_sınama DOĞRU ise ve eğer_doğruysa_değer boşsa, bu bağımsız değişken 0 (sıfır) değeri verir. DOĞRU sözcüğünü görüntülemek üzere bu bağımsız değişken için DOĞRU mantıksal değerini kullanın. Eğer_doğruysa_değer başka bir formül olabilir. Eğer_yanlışsa_değer Mantıksal_sınama YANLIŞ ise verilen değerdir. Örneğin, metin dizesindeki bu bağımsız değişken “Bütçeyi aşıyor” ise ve mantıksal_sınama bağımsız değişkeni YANLIŞ olarak değerlendirilirse, EĞER fonksiyonu “Bütçeyi aşıyor” metnini görüntüler. Mantıksal_sınama YANLIŞ ise ve eğer_yanlışsa_değer belirtilmemişse (bu, eğer_doğruysa_değer’inden sonra virgül olmamasıdır) YANLIŞ mantıksal değeri verilir. Mantıksal_sınama YANLIŞ ise ve eğer_yanlışsa_değer boşsa (bu, eğer_doğruysa_değer’inden sonra bir virgül ve onu izleyen kapatma parantezi olması durumudur) 0 (sıfır) değeri verilir. Eğer_yanlışsa_değer başka bir formül olabilir.

  • Daha ayrıntılı sınama yapmak için en çok 64 EĞER fonksiyonu eğer_doğruysa_değer ve eğer_yanlışsa_değer bağımsız değişkenleri şeklinde iç içe kullanılabilir.
  • Eğer_doğruysa_değer ve eğer_yanlışsa_değer bağımsız değişkenleri değerlendirildiğinde, EĞER fonksiyonu bu deyimler tarafından verilen değeri verir.

Bu Konuda İlginizi Çekebilir

BTT Dersi Ödevi İşletim Sistemleri ve BIOS

Aşağıdaki linkteki ödevi belirtilen tarihe kadar resimleri yapıştırarak ve okuyup, anlayarak defterinize yazınız. Belirtilen tarihten …

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir